I like the idea in general (as I’ve briefly proposed it myself earlier in a comment here at WICG).
I’m not sure about exact keywords for value though. It probably makes sense to use
hide) which are more consistent with existing CSS keywords (
none is used widely (e.g.
hide are used e.g. in the empty-cells property).
Also, the property could probably be named just
tooltip instead of